How do I disable machine sounds in IC2?

I’m getting an error that is making my game unplayable.

Error in class ‘SourceLWJGL OpenAL

  • Removing some hostile creatures in minecraft
  • What can I do to secure my towns/castles/hovels from climbing spiders?
  • How to put a copied command in a command block?
  • Condensed Mob Names in Scoreboard
  • How can I make a boatlock in Minecraft?
  • Minecraft Failed To Bind Port
  • Channel null in method ‘stop’

    Some google searches show this is a error involving IC2 machine sounds, but I cannot find anything in the .cfg file to disable these sounds. How can I disable the machine sounds from IC2?

    My IC2 version is industrialcraft-2_1.116.364-lf, it is the most updated version of IC2 I’m aware of that I can use in my modpack (minecraft version 1.5.2), which is primarily Unhinged (some other mods added)

    Edit: I have since updated LWJGL incase that was the issue, it is not. The only way to ‘fix’ this I can find is to disable the sounds, and I cannot find how to do that.

    Edit2: I found a post on a forum that mentions disabling the sounds in the ‘Advanced Machines’ .cfg file. It says to do it by putting a # in front of several lines in the config to ‘comment the lines out’. I understand this method, it’s simple enough and isn’t the first time I’ve had to do something like this.

    What I do is take the server offline, edit the config, and start the server back up. The issue now is that when I start the server back up, the config file reverts back to its original state. I have never had a config file behave this way and am completely stumped on how to prevent this from happening. I’m fairly sure that if I can get the config file to keep its edits, then the problem will be fixed. Any ideas?

    Edit3: I’ve figured out I was going about disabling the Advanced Machine sounds incorrectly, I have properly disabled them now, however the bug persists.

    Edit4: Some forum posts stated that lowering graphics to ‘fast’ from fancy or disabling sound from minecraft in its options works. Neither of these solutions work for me. I have also attempted disabling all sound from Gravisuite and that didn’t work either. It is probably worth mentioning that I’ve been playing without changing anything in my files\settings for weeks without issue, and this has suddenly cropped up out of nowhere.

  • How do spawners work going in and out of the radius?
  • Why can't I destroy or place blocks?
  • What could cause a Minecraft portal to not work?
  • Advanced Pump vs BuildCraft Pump
  • What is Redstone used for in Minecraft?
  • “Minecraft Offline.bat” With HD texture pack Fix?
  • One Solution collect form web for “How do I disable machine sounds in IC2?”

    Try downloading this fix

    Overwrite the IC2.class, AudioManagerClient.class and
    AudioSourceClient.class files with the ones contained in this archive
    in the ic2 jar.

    This should solve the problem.

    We love Playing Games, especially Video Games.